A Quick Start Guide to ExpertGPS

Thanks for choosing ExpertGPS. This guide will help you get up and running with ExpertGPS and guide you through the most common uses of the software. To get the most out of ExpertGPS, it will help to understand the basic philosophy behind the major features in ExpertGPS.

ExpertGPS Mastery in 30 Seconds

Every action in ExpertGPS is undoable. If you're not sure what to do, experiment.

Right-click is your friend. To find out what you can do with an item, select it and right-click. You'll get a popup menu of common commands for that kind of object. ExpertGPS has different popup menus for each kind of object, and they change based on whether you've selected one object, multiple objects, or nothing at all. Try right-clicking on a blank spot on the map, or on the column headers in the data list.

If a command is greyed out on the main menu, you probably need to select an object to act on first. Some commands, like the Join command, require two or more objects to be selected. The status text in the lower left corner of the main window gives you hints on how to use the command.

To work with files in ExpertGPS' native GPX format, use Open or Save on the File menu. For other types of data files, use Import and Export on the File menu, or the Convert menu. For Garmin, Magellan, or Lowrance GPS data files, use Receive from GPS or Send to GPS on the GPS menu.

If your GPS numbers don't match what's shown in ExpertGPS, click Change Coordinate Format on the Options menu and select the same format and datum used on your GPS. You can convert data to a new coordinate format this way, too. If you're exporting data to another program, use Change Coordinate Format before you export so that your data will match up.

You'll see hotkey shortcuts listed next to many of the common menu commands, making it easy to switch between background maps or to select a new map tool to work with.

Most tasks and conversions in ExpertGPS should be self-explanatory, but there are some tasks that require multiple steps. I've walked through these in detail at https://www.expertgps.com/tutorials/ If you still need assistance, click Get Support for ExpertGPS on the Help menu, and I'll be happy to help.


That's it – you're an ExpertGPS expert now. Have fun.


– Dan Foster, author of ExpertGP.

p.s. Read on for some more tips on getting the most out of ExpertGPS.

GPX Files

ExpertGPS displays your GPS, GIS, and CAD data over street and topo maps and aerial photos. Your data is stored in GPX files, while the maps are managed behind the scenes by ExpertGPS, and stored on your hard drive. GPX files store GPS waypoints, routes, and tracks, and any line or polygon data you import from other programs. GPX files don't store maps. Instead, ExpertGPS (or any other program that supports GPX) will display your data over your choice of background maps. To share a map with data exactly as it appears in ExpertGPS with another person, consider using the Image Export command, or print to a PDF.

Kinds of Data in ExpertGPS

ExpertGPS lets you work with these kinds of point, line, and polygon data: waypoints, routes, tracks, shapes, notes, photos, and geocaches. Let's look at each of these:

GPS data: waypoints, routes, and tracks

Waypoints are points that can be sent to or from your GPS receiver. Routes are a series of GPS waypoints that define a path to follow. ExpertGPS is not turn-by-turn street routing software, so the legs between points of the route follow straight-line paths (as the crow flies). Routes are typically used by hikers or sailors to navigate to a destination. Tracks are GPS tracklogs (breadcrumb trails) that show exactly where you went while carrying your GPS. You can also trace trails off of the maps in ExpertGPS and send them to your GPS as tracks to be followed.

Map drawing data: shapes and notes

Shapes are similar to tracks, except they don't get sent to your GPS. If you simply want to draw a line or a polygon on the map, use a shape. Shapes don't have GPS time or speed data associated with them, so they take up less memory. If you import data from shapefiles or CAD drawings, all of your polyline and polygon data will be imported as shapes. You can convert back and forth between shapes and tracks, if you need to send a specific shape to your GPS.

Notes are text annotations you can place on the map. They're similar to waypoints, but they don't get sent to your GPS.

Photos

ExpertGPS can display your camera's JPEG photos right on the map, in the exact location where they were taken. If your photos were taken with a GPS or GPS-enabled camera, this happens automatically. Otherwise, you can use the Geotagging feature in ExpertGPS to position them.

Geocaches

Geocaches are a special form of waypoints used to find hidden "treasures". If you're a geocacher, use the Import Geocaches command on the Geocaching menu to get started.

Types

Types are probably the most powerful, and least-utilized, feature of ExpertGPS. Types organize your waypoints and tracks (and all the other kinds of data), and control how they are displayed on the map.

Consider a road map. When you see thick, red lines, thinner black lines, and thin dashed lines, you automatically know that you're looking at highways, roads, and dirt tracks. Each type of line you see on the map represents a different type of roadway. The Type field in ExpertGPS does the exact same thing.

When you draw or edit an object in ExpertGPS, the first thing you'll see at the top of the Edit dialog is the Type Selector. For tracks, you can choose between several road types, or click New and create your own types that describe the real-world features you're mapping. For each type you create, you define the colors and line patterns that are used to draw it on the map. Now, the next time you trace a "75 kilovolt transmission line" or "16 inch drain pipe" on the map, simply select that type and all of these objects will be displayed in the same way. And because ExpertGPS automatically assigns the last type you used to the next shape you draw, most of the time that step will be done for you.

When creating Waypoint Types, you'll also choose the default GPS symbol to assign to waypoints that are given this type. And new waypoints that you receive from your GPS that have that symbol will automatically be assigned the matching Waypoint Type.

Get in the habit of assigning descriptive types to all of your data. ExpertGPS will work better if you do, and the descriptions will help the people you share data with to understand what it is you are mapping.

Working with the Data Lists

The left side of the ExpertGPS window displays a list of one of the data types above. The right side displays a map. You can drag the divider between the two all the way to the left or right to hide one of these views.

At the top of the list view is a selector that lets you switch between the lists (waypoints, routes, etc) and also indicates how many items of each data type are in the file you're working on. There's also a Find box. Typing here filters the list to show only the items that match what you're typing. The others are hidden from view. The Clear button brings them back.

Each item in the list is displayed on it's own row, with columns of data, just like in a spreadsheet. You can click on any of the column headers to sort by that column, and you can quickly edit the data in a column by right-clicking a data cell and clicking Quick Edit, or by pressing F2. Some data columns are read-only and cannot be edited. If a column's contents are shown in italics, this data has an autogenerated default value based on another column's value. You can edit and overwrite this value.

There are other columns besides the ones initially visible. Click Select Columns on the List menu to select which ones you want displayed.

Working with Maps

ExpertGPS can display your data over a number of different background maps. You'll see all of these options at the top of the Map menu. Street and aerial photos are available worldwide. USGS topo maps and NOAA nautical charts are available in the United States. Additionally, you can display your data over a plain, white background for speed, and you can add your own scanned maps or digital charts to ExpertGPS using the Scanned Maps sub-menu.

Whenever you view a new place in ExpertGPS, the program automatically retrieves map tiles for that location, and stores them on your hard drive. The next time you view that location, the maps are already loaded, and can even be viewed if your computer is off line.

Map Tools

Just like in a image editor or painting program, your primary way of interacting with the map is through a variety of tools, which you'll find on the Tools menu. Here you'll find tools to move around the map, create new data, select objects, and edit them.

Moving around the map

The Move Map tool lets you grab the map and drag it around. You can also use the cursor keys and the numeric keypad for this. To zoom in and out by a factor of two, use the Zoom tools (holding Alt reverses the zoom direction), press + or -, or roll the mouse wheel. You can also drag a zoom rectangle over the map to zoom in on a specific object. To change the map scale to a precise value (like 1:24000), click Zoom to Scale on the Map menu.

Creating new data

Each of the five main data types (waypoint, route, track, shape, note) have their own tool on the Tools menu. For waypoints and notes, click to create. For routes, click once on each waypoint to include it in the route, or click on a blank space on the map to create and add a new route waypoint. For tracks and shapes, click to draw straight lines, and drag to draw curves. Double-click or hit Enter or Escape to end the drawing.

Selecting objects

Most of the commands in ExpertGPS work on whatever objects are currently selected. Click with the Select tool to select single items. Hold Shift or Command to add additional items to the selection. Click and drag to select everything within a rectangular area. Hit Esc to clear the selection.

Editing objects

Select something first. Right-click to see all of the editing commands that act upon the object or group of objects. You can also hit Enter to edit the object, Backspace to hide it, or Delete to delete it. The Move Selected tool lets you drag an object to a new location. The Scissors tool lets you snip out bad data in your GPS track logs, and can also be used to delete objects.

Working with GPS Receivers

ExpertGPS works with pretty much every handheld and dashboard GPS receiver from Garmin, Magellan, Lowrance, and Eagle, including models with serial cable, USB cable, and file-on-SD-card interfaces. ExpertGPS can work with multiple GPS models from multiple manufacturers, which means you aren't locked in to a particular brand's hardware or software and can easily move your data to another manufacturer's GPS in the future.

The first step in connecting your GPS is to select it by clicking Add a New GPS Receiver on the Options menu. GPS models are listed alphabetically, so look closely if you don't see your model – it's probably there.

If your GPS uses a USB cable interface, you'll need to plug it in and wait for Windows to recognize and install any device drivers for your GPS. Try to use the same USB port every time you connect. If you get an error message from ExpertGPS that your GPS wasn't found, it probably is still connecting. Wait 3 minutes and try again. Garmin GPS that use USB should be in Mass Storage mode. Older Garmin units with serial cable connections should be in Garmin or GRMN HOST mode. Check your Garmin manual for instructions on changing the Interface mode on the Setup page on your GPS.

Use the Send to GPS and Receive from GPS commands on the GPS menu to transfer data to and from your device. You can also right-click selected data and Send Selected to GPS.

If you have a Lowrance GPS that stores data to .usr files, or a Magellan that uses .upt or .wpt files, you'll still use Receive from GPS to transfer your data. You'll be prompted to locate the data file on the SD card that you want to bring into ExpertGPS.

When sending waypoints and tracks back to your GPS, make sure each item has a unique name in the Waypoint Name or Name on GPS field.

There's no way for ExpertGPS to delete or rename data directly on your GPS. Instead, to modify or delete data on your GPS do this: Receive all data from your GPS. Save a copy, and then make your changes and deletions in ExpertGPS. Use the Remove All Data or similar command on your GPS receiver to clear it's waypoint and tracklog memory – check your GPS manual for the exact procedure. Then, send the edited data back to the GPS from ExpertGPS.

In addition to transferring waypoint and track data, some GPS receivers can output their current position and speed information to ExpertGPS, allowing you to plot your location directly on a moving map display. Click Enable Real-Time Tracking on the GPS menu to get started. Many GPS models require you to switch the Interface setting to NMEA Out while tracking, and then switch it back for data transfer. For newer USB models, ExpertGPS can do this automatically.

Cleaning up GPS data

ExpertGPS was originally written to make it easy to clean up and add descriptive text to your GPS data. When you come home from a trip with a bunch of waypoints cryptically named WPT001, WPT002, etc, and a GPS track recording with dropouts and glitches caused by bad satellite reception, ExpertGPS is your fix. Start by going through and renaming or labelling all of those waypoints, giving them proper names and descriptive map labels, and use the Type field to describe exactly what type of object you were marking.

If you have a Garmin GPS, your tracklogs are probably all named ACTIVE LOG. Give them a better name and description, and include a label if you want the labelled on the map. Now look for glitches in the track that need to be cleaned up.

If the GPS got turned off or lost reception during your outing, you may have two tracks that should be one. Use the Join command by clicking on the first track, and then holding shift to select the second track as well. Right-click, and Join. The Join command joins tracks in the order they were selected and in the direction they are pointing, so if you are joining tracks that you recorded over several days or recorded from different directions, you may need to Reverse Track first. Use Undo if you don't like the results you see.

Conversely, to separate a track into two parts, you can Break or Split it. Break knocks out the piece of track between the two nearest track points, which is useful if you moved to a new place with the GPS off and the GPS drew a big straight line to the new location. Split creates two pieces without a break between them.

To use the Split and Break commands, click once on the track with the Select tool. You'll see an orange triangle at the point where you clicked, and all of the points in the track will be drawn in black against the selected track in yellow. That arrow serves two purposes. It points in the direction the track was recorded. And it acts as the Track Marker, which is where the Split or Break will occur. Right-click on the track and you'll see these two menu options.

Using Split, you can quickly cut out and delete weird sections of GPS tracklogs, and then Join them back together. You can also draw in missing pieces of track, by holding the Track tool over the end of an existing track. You'll get a + cursor, indicating that you'll be extending the track rather than drawing a new track.

The other track repair technique involves dragging the Select tool over points in a selected track, or along the track itself. The resulting Track Selection will be highlighted in magenta. Hitting the Delete key now will delete the magenta track selection, rather than the entire track.

Printing

The Print Map command on the Map menu brings up a blue rectangle outlining the area of the map that will be printed, and a dialog with options to enter a title for your map and customize how the map will be printed. You can drag the print rectangle around with the Move Selected tool, or change the map scale to print to a specific scale like 1:24000. I also like to open the Map Display Options dialog (on the Options menu) to adjust the spacing of the coordinate grid and the size of the printed text. You'll see a full preview before anything is printed.

Because some of the background maps (street and topo) show different details at different zoom levels, the Print Map dialog has an option to print at the current screen zoom level, or at one or two levels of closer detail. If there are map tiles that need to be downloaded before your map can print, you'll see a status display in Print Preview. Wait for the countdown to reach zero, and then you can print.

Exporting Images

Image Export is similar to Print. Click Export Image on the Map menu, adjust the blue rectangle to cover the area you need, and export to a JPEG or PNG file.

Photos and Geotagging

JPEG photos can contain latitude and longitude information that marks the location where they were taken, as well as descriptive information about the photo's content. ExpertGPS can read this information and place the photos right on the map. In addition, because most photos contain a timestamp of the time they were taken, if you carry a GPS receiver with you while taking photos with your camera, ExpertGPS can match up the timestamps from the photos with the time data recorded in the GPS track log, and automatically position your photos for you. This is called Geotagging. Here's how to do it: https://www.expertgps.com/geotag-photos.asp

Calculating Area and Acreage

ExpertGPS can calculate acreage for just about any shape you can draw on the map - even complex polygons with inholdings or islands. You can use the aerial photo map in ExpertGPS to zoom in on a property and trace boundaries or fence lines. Or, you can go out into the field with a GPS and walk the perimeter, recording a tracklog or marking waypoints at corners.

Back in ExpertGPS, you'll either have a route, track, or shape outlining your property. Right-click and Edit, and you should see the area listed. I like to create a new Shape Type called Field or Property, and give it a transparent, solid fill color so that the entire parcel is highlighted on the map. Then, I copy the acreage shown into the Label for the shape. If you'd like to include both the property name and the area on the map, you can use \n to create a new line in the Label: "Soybeans\n4.5 acres" More info: https://www.expertgps.com/calculating-area-with-a-gps.asp

Converting Coordinate Formats

To convert data between two coordinate formats, you can take advantage of the way ExpertGPS uses the active coordinate format when importing and exporting data. Some file formats, like GPX and KML, always use the same coordinate format and datum (lat/lon WGS84). But CSV, SHP, and DXF can be in any format, and ExpertGPS can import in one format and then export in another. All you need to do is to change the active coordinate format to your output format before exporting. Use Change Coordinate Format on the Options menu, or select it from the popup list by clicking the name of the active coordinate format shown in the lower right corner of the main ExpertGPS window.

Converting between file formats

You can use ExpertGPS as a file converter. Simply open or import the file you want to convert, change coordinate formats if needed to match the coordinate system of the program you're targetting, and then export or save in the desired output format.

Importing and Exporting Files

ExpertGPS is all about data portability. The native GPX file format that ExpertGPS uses is the world's standard for exchanging GPS-based data. I was one of the founding authors of the GPX standard, and ExpertGPS has a robust GPX implementation that supports data interchange better than any other program I know of. If you do find an older GPX-enabled application that isn't reading your ExpertGPS files correctly, try exporting GPX 1.0 data for it using Export on the File menu.

In addition to GPX, ExpertGPS supports Google Earth's KML and KMZ formats, and can read and write CSV data from spreadsheet programs like Microsoft's Excel. ExpertGPS Pro imports and exports ESRI shapefiles and CAD files in DXF format. Here are some notes to help you with each of these formats.

Google Earth KML and KMZ

To view your GPS, GIS, or CAD data in Google Earth, you can either export a KML or KMZ file, or click View in Google Earth to automatically launch Google Earth with your data showing. If you use Export on the File menu to save KML files, you'll see several options. These allow you to control whether your data is clamped to the ground (the correct behavior for most of us) or should be plotted above the ground (airplane flights). Additionally, you can include timestamps, which will bring up the time slider in Google Earth, which generally isn't what you want.

You can copy and paste items from Google Earth directly onto the map ExpertGPS, which is really handy for getting driving directions. And if you're a hiker, try marking a waypoint on your favorite summit, right-click it, and See the View from Here in Google Earth.

Occasionally, you may receive a KML file that was created in a 3rd-party program that fails to import into ExpertGPS, although it displays in Google Earth. There are a lot of broken programs out there creating broken KML files. The XML parser that ExpertGPS uses won't tolerate invalid KML, even if Google Earth does. Send these files back to their creators, and help make a better world for us all.

CSV, Tab-Delimited Files, and Excel

Getting your waypoint or trackpoint data from ExpertGPS to Excel is straightforward. Either export as CSV, or simply copy and paste to your spreadsheet. Bringing delimited data back into ExpertGPS is trickier, because you have to do it correctly. You need to start with properly-formed delimited data, with the same number of columns for each row. Next, you have to know the exact coordinate format and datum used in your data, and select the matching coordinate format and datum in ExpertGPS when you import. Finally, you have to match the columns from your data up with the fields that ExpertGPS uses. For example, you might have a column called site_lat that you match to the ExpertGPS latitude field, and a column called site_owner that you match to the Label field in ExpertGPS. Matching up the coordinate fields (latitude and longitude, or easting and northing) is required, but all other fields are optional.

Shapefiles

Importing and exporting shapefiles is pretty easy in ExpertGPS, especially if you have a .prj file that tells you (and ExpertGPS) the exact coordinate format and datum in use. Just like with CSV, when you import a shapefile, you have the option to match the data table in the .dbf to fields in ExpertGPS. Point shapefiles will become waypoints, and polylines and polygons will become shapes. If you have shapes you want to send to a GPS, right-click them and Convert to Track, and then make sure they each have a unique Name on GPS.

When exporting a shapefile, ExpertGPS uses the current coordinate format and datum. Click Change Coordinate Format on the Options menu if it doesn't match your GIS.

CAD drawings in DXF Format

ExpertGPS can import and export DXF files, but not DWG. Convert to DXF first.

If your CAD drawing uses a well-known coordinate system like UTM or a national grid for its X,Y coordinates, you're golden. Simply specify the coordinate system when importing the DXF, and ExpertGPS will do the rest. If you have architectural or landscape drawings that are done to a specific scale (¼ inch = 1 ft, e.g.) and use a local origin, you've got some work to do when importing the drawing. ExpertGPS needs to know how to convert the local X,Y coordinates in your drawing into latitudes and longitudes or eastings and northings. You'll do this by providing two tie points that map the two coordinate systems together. Let's say you have a drawing of a large industrial facility. Pick two easily-identifiable points (like the corners of buildings, or the intersections of roads) and write down their X,Y values as they're given in the CAD drawing. Now switch to the aerial photo in ExpertGPS, and find those points and determine their UTM northings and eastings. (Or, take a GPS to the facility and mark the points as waypoints). Click Import DXF with Local Origin on the Convert menu, select UTM or your national grid as the coordinate system, and enter the CAD X and Y values and the real-world easting and northing values for each of the two tie points. ExpertGPS will use this mapping to translate all of the points in your DXF into real-world coordinates.

This can be difficult the first time, so contact me if you need help after walking through the tutorials at https://www.expertgps.com/tutorials/

ExpertGPS is mapping and file conversion software for your Garmin GPS
ExpertGPS is mapping and file conversion software for your Magellan GPS
ExpertGPS is mapping and file conversion software for your Lowrance GPS
ExpertGPS works with hundreds of GPS receivers, including all Garmin Drive, nüvi, eTrex, Colorado, Dakota, echoMAP, GPSMAP, Edge, Forerunner, Montana, Oregon, and Rino models, Magellan eXplorist, Meridian, and SporTrak GPS receivers, and Lowrance iFinder, HDS, Elite, HOOK, LCX, and LMS GPS chartplotters and fishfinders. Download ExpertGPS
Find your GPS on the ExpertGPS compatibility list.

© 1998-2020 TopoGrafix – 24 Kirkland Dr, Stow, MA – Email: support@expertgps.com – Fax Orders: (815) 346-5239